Community News: Latest PECL Releases (01.19.2021)

Latest PECL Releases:

  • SeasLog 2.2.0
    – Support PHP8

    • Support s390x and mips64 platform
    • Fixed ulong conflicting
    • Fixed test case dependence on INI setting (seaslog.default_template)
    • Fixed memory leak on get_code_filename_line
  • mysql_xdevapi 8.0.23
    WL#14014: XProtocol: Support connection close notification
    WL#14228: Replace language in APIs and source code/docs
    orabug #30134451: mysqlndx replace raw zval with improved zvalue where possible
    orabug #31589457: change default engine from MyISAM to InnoDB

  • varnish 1.2.6
    – Fix missing header

  • xmldiff 1.1.3
    – fix inappropriate xmlCleanupParser usage
    – Fix PHP 8.0 compatibility (Remi Collet)
    – Apply latest compat patches to bundled diffmark

  • varnish 1.2.5
    – Fix PHP 8.0 compatibility (Remi Collet)

  • trader 0.5.1
    – Fixed PHP 8.0 support

  • parle 0.8.2
    – Fixed PHP 8 compatibility (Remi Collet)
    – Fixed PHP 7.4+ compatibility (Remi Collet)

  • gearman 2.1.0
    PHP 8.0.x is now supported

  • xmlrpc 1.0.0RC2
    This is the snapshot of ext/xmlrpc just before it was unbundled from php-src.
    Only minimal modifications have been made thereafter.

  • rdkafka 5.0.0
    ## Enhancements
    – PHP 8 support (@nick-zh, @arnaud-lb)
    – Suport passing an opaque value in produce(), producev() (@arnaud-lb)

    Breaking changes

    • Dropped PHP 5 support
  • pecl_http 3.2.4
    * Fixed configure on systems which do not provide icu-config
    * Fixed gh-issue #89: Cookie handling cannot be disabled since v3.2.1

  • pecl_http 4.0.0
    > *NOTE:*
    v4.x is PHP-8 only.

    • PHP 8 compatibility
      • Drop ext-propro support
        PHP 8 removes the object get/set API from the ZendEngine, which renders
        that extension dysfunctional. As a consequence, the header property of
        httpMessage and derived classes cannot be modified in place, and thus
        by reference.

    Changes from beta1:

    • Fixed configure on systems which do not provide icu-config
    • Fixed gh-issue #89: Cookie handling cannot be disabled since v3.2.1

from PHPDeveloper.org https://ift.tt/2XSKRFh
via IFTTT

Leave a Reply

Back to Top