Уязвимость в Python, проявляющаяся при обработке непроверенных дробных чисел в ctypes

Доступны корректирующие выпуски языка программирования Python 3.7.10 и 3.6.13, в которых устранена уязвимость (CVE-2021-3177), способная привести к исполнению кода при обработке непроверенных чисел с плавающей запятой в обработчиках, вызывающих функции на языке Си при помощи механизма ctypes. Проблема также затрагивает ветки Python 3.8 и 3.9, но обновления для них пока находятся в состоянии кандидата в релизы (релиз запланирован на 1 марта).

from OpenNews.opennet.ru: Проблемы безопасности https://ift.tt/3avxTEr
via IFTTT

Leave a Reply

Back to Top