Уязвимость в пакетном менеджере Composer, допускающая компрометацию PHP-репозитория Packagist

В менеджере зависимостей Composer выявлена критическая уязвимость (CVE-2021-29472), позволяющая выполнить произвольные команды в системе при обработке пакета со специально оформленным значением URL, определяющим адрес для загрузки исходных текстов. Проблема проявляется в компонентах GitDriver, SvnDriver и HgDriver, применяемых при использовании систем управления исходными текстами Git, Subversion и Mercurial. Уязвимость устранена в выпусках Composer 1.10.22 и 2.0.13.

from OpenNews.opennet.ru: Проблемы безопасности https://ift.tt/3eQk9oC
via IFTTT

Leave a Reply

Back to Top