Разработчики PostgreSQL опровергли наличие уязвимости в COPY..PROGRAM

В ответ на появление в СМИ спекуляций, основанных на отчёте об уязвимости CVE-2019-9193, разработчики PostgreSQL опубликовали опровержение. CVE-2019-9193 преподносится некоторыми аналитиками как критическая удалённо эксплуатируемая проблема, позволяющая в конфигурации по умолчанию через манипуляции с конструкцией “COPY TO/FROM PROGRAM” выполнить произвольный код с правами пользователя, под которой запущена СУБД. Данные заявления не соответствуют действительности, описанная проблема надумана и CVE-2019-9193 на деле не является уязвимостью. Идентификатор уязвимости CVE-2019-9193 выдан по недосмотру.

from OpenNews.opennet.ru: События http://bit.ly/2uLHfpR

Leave a Reply