В Rust будет прекращена поддержка старых Linux-систем

Разработчики проекта Rust предупредили пользователей о скором повышении требований к окружению Linux в компиляторе, пакетном менеджере Cargo и стандартной библиотеке libstd. Начиная с версии Rust 1.64, намеченной на 22 сентября 2022 года, минимальные требования к Glibc будут подняты с версии 2.11 до 2.17, а ядра Linux c 2.6.32 до 3.2. Ограничения также распространяются на исполняемые файлы Rust-приложений, собранных с libstd.

source https://www.opennet.ru/opennews/art.shtml?num=57582

Leave a Reply

Back to Top